Posts by marmot

1) (Message 5499)
Posted 16 Sep 2017 by marmot
Did Computer 52516 perform a heist?

I guess it's being assigned credit from another of my older computer configurations because my total credit seems unchanged.

How did the credit get moved?

Computer 270285 and Computer 259620 were the two main crunchers for the period of Nov 2014 till I stopped running Asteroids in Nov 2016. By their CPU's, the 1,177,800 credit should be split about 2/3 to computer 270285 and the other 1/3 to 259620.

There was a database problem sometime last year and I remember you all had to rebuild from backups and the credit must have been floating till I ran a new WU on the new machine.

Is that a correct summation?
2) (Message 4686)
Posted 8 Nov 2015 by marmot
Version 3.6.9 of what?

That was a typo for 7.6.9 of BOINC manager.

I never needed/wanted to try it but sometimes this happens on its own.
See how on ~ 17 Jul 2014 I had >100 new hostids created (I deleted most of them):

Happens (maybe) when Internet is not working good - "theory" is one Scheduler request is delayed somewhere on the Internet, second Scheduler request is sent OK, then the first is "unlocked" and reaches the server.
Server see out of order Scheduler requests (lower rpc_seqno reaches the server after higher) and generates new hostid

Another example and (opposite) advice "How to revert to an older HostID number?"

Yeah, I tried and succeeded to change the HostID to a previous version with just a simple edit of the state file.

Claggy: "As i said, you can't just go and revert to a copy of Boinc with less contacts than the server knows about, it'll eithier give you a new host id, or abandon your work,"

He states:
"and change the <rpc_seqno> number for Seti to one or two [i]greater[/i] than what the Computer details page says,
restore Network connectivity,..."

Which is not what I tried. I set the rpc_seqno to a lesser number and the network was probably running at the time. This may very well be the solution to setting the sequence a not yet achieved number, instead of to a past sequence.

HAL9000: "From time to time I generate new IDs for my machines":

But maybe the server is sometimes "too smart" - you may need to change also the computer name?

That's what I was wondering if you had attempted it since client 7.6.9 had been released and maybe the server side HostID assigning code has also changed since 2014.

I think Josef W. Segur knows the source code of BOINC server and may definitely tell the conditions needed for a new hostid - if you want to PM him:

Or post at SETI@home Number Crunching

I'll try this again sometime but for this event I just reinstalled BOINC to a different directory and changed the computer name. Reinstalling BOINC to the same directory without cleaning the Registry of all BOINC traces would just come back with the same HostID. I didn't try the case of keeping the computer name the same and installing to a new directory to see if both variables were necessary.

Results of the new HostID and experiemnt with 3 methods to calculation Asteroid@home data:
Asteroids@Home offers up SSE2, SSE3, AVX code and after getting the new HOSTID the server sent down hundreds of SSE2 and AVX's for the Dell e5420 and the HP8560w but sent only requested 1 SSE3 WU to the HP. I set the Anonymous client to test SSE3 speed but the data sets from day to day would be slightly different so I'm still not sure which algorithm is fastest on this HP8560w i5 2nd gen. It appears that AVX ~5%>SSE3 ~5%> SSE2 when running 4 WU BUT the other 2nd Gen i5 (e5420) is running 1 WU at a time and the SSE2 seems to be beating SSE3 and AVX and the server has locked in SSE2 on that other machine. Either Asteroids@Home has more efficient code for SSE2 that allows multi-threading even though 1 core is chosen in BOINC settings or the CPU uses burst mode more often on SSE2 algorithms. SSE2 being faster in single WU mode surprised me.
3) (Message 4660)
Posted 17 Oct 2015 by marmot
Followed the steps again for Moo! project
(I forced Asteroids to send SSE3 by aborting an entire day of SSE2 WU's, since server refused to send SSE3 even when SSE2 turn-around was 1.18 days>1.16 days for SSE3)

Stopped BOINC
Edit <rpc_seqno>29</rpc_seqno> to <rpc_seqno>11</rpc_seqno>
Save client_state.xml
restart BOINC
BOINC updated Moo! automatically upon restart.
Log file reads:

2015-10-17 03:14:22 PM | Moo! Wrapper | Sending scheduler request: To fetch work.
2015-10-17 03:14:22 PM | Moo! Wrapper | Requesting new tasks for AMD/ATI GPU
2015-10-17 03:14:24 PM | Moo! Wrapper | Scheduler request completed: got 0 new tasks
2015-10-17 03:14:24 PM | Moo! Wrapper | Generated new computer cross-project ID: d38e1eceef12f9bc415b52c8fad21dc2

Clicked Update on Moo! project and event log reads:

2015-10-17 03:15:41 PM | Moo! Wrapper | update requested by user
2015-10-17 03:15:46 PM | Moo! Wrapper | Sending scheduler request: Requested by user.
2015-10-17 03:15:46 PM | Moo! Wrapper | Requesting new tasks for AMD/ATI GPU
2015-10-17 03:15:49 PM | Moo! Wrapper | Scheduler request completed: got 0 new tasks

Checked Moo! account to see No new HOSTID's created

Checked the client state file to find <rpc_seqno>1</rpc_seqno>.

Have you tried this since version 3.6.9 came out?

Correction to above post: New 8560p HOSTID created
4) (Message 4658)
Posted 15 Oct 2015 by marmot

Change rpc_seqno backwards.
From the above example (which is from my client_state.xml) you may make it e.g.:


I tried your method and it didn't change the HOSTID. For the Moo! WU the entry looked like:

which I changed to <rpc_seqno>22</rpc_seqno> then started BOINC and reset the Moo! project.
Now it's <rpc_seqno>0</rpc_seqno> with the same HOSTID and new set of WU d/led.

Also tried changing the <HOSTID>32476</HOSTID> to another number but of course that would only change if it was a HOST already attached to my account ID.

Next attempt at correcting this, without reinstalling BOINC, was to do some maintenance of merging the two 1090t HOSTID's into one and now the SSE3 has an average turn around of 1.17 days while the SSE2 has 1.14 days.
There are 8 WU's sitting in queue and suspended.
Will the SSE2 average climb to greater than 1.17 as those SSE2 WU's sit there suspended while 24 to 48 hours passes without any WU coming back?

I calculated that if these 8 WU are allowed to start after 3 days then my average on 310 WU should then exceed 1.18 days turn-around and then would be greater than the SSE3 1.17 days and get the server to d/l SSE3 WU's. So in 3 days I'll either have SSE3 WU or reinstall BOINC.

It would be nice if the faster HOSTID tactic worked.
5) (Message 4654)
Posted 10 Oct 2015 by marmot
The OS certainly did not need to be reinstalled. All that had to be done to get the AVX app working the data on the 8560p, is change the computer name, copy the project folders to a safe place, then uninstall BOINC with an uninstaller (like Revo) to make sure all registry entries are removed (the uninstall and reinstall might be unnecessary and only a project remove/re-add or reset might be all that is needed), reboot the machine then reinstall BOINC and finally copy the old BOINC folder back to restore the other projects work making sure not to copy over newer files from the new installation.

This is the old HOST ID for the HP 8560p a new Host ID named 8560p was created. A problem occurred that upon clicking update, the server decided to send 18 WU's and then choice to use the SSE2 app to compute on them. It only downloaded the period_search_10210_windows_x86_64__sse2.exe application. I reset the project and clicked update and then 42 new WU's came down, along with the period_search_10210_windows_x86_64__AVX.exe executable, and are being worked on by the AVX app.

Wish that resetting the project was enough on the old installation. The 1090t machine is supposed to be using SSE3 for optimal data crunching but is using SSE2 so I'll try just doing a project reset, then a name change+project reset and see if that fixes it's problems.

I tried various combinations of resetting the Asteroids@Home project, removing the project then re-adding, then resetting it on the 1090t machine but the server refuses to use SSE3 application on the WU's. I'll have to change the machine name, and possibly only need to remove Asteroids@Home then re-add it and reset the project. The reinstall is probably unnecessary too.
6) (Message 4653)
Posted 10 Oct 2015 by marmot
My last post excluded that you'd need to rename the machine after a fresh install of a new OS (yeah, huge omission, sorry). It should be possible to get away with not having to install a new OS and I'll post what was necessary to accomplish that after I figure it out. You just need to get a new Host ID for the machine.
7) (Message 4652)
Posted 10 Oct 2015 by marmot
So there is no other method to force the server to use the AVX application than using the app_info.xml anonymous platform solution?

I tried the modified app_info.xml method and am forcing the HP8560p to run two WU of SSE3 x64, SSE3 x86, and AVX x64 and comparing results but I want the history of WU data to be factored into the results here and not show up as anonymous since the native apps are actually being used. This method isn't going to convince the server that AVX is faster if it shows up as anonymous platform/CPU.

One solution I tried was to delete all applications but the AVX 64 bit version with the result of the server refusing to send WU's.

There is one solution that will work with some special care given to the machine in the first week of operations. Rename the computer so that the server starts a new data record and a new application history. This would lose this machine it's WU history though and I'm not liking that solution.

EDIT: I'm going to rename the 8560p and leave it run 2 cores at top speed (Throttlestop setting the i5 to 32x clock) and use it for nothing else for a week and hopefully get the server to settle in on the AVX app.

This is going to be more of a problem as the desktop market continues it's declines and BOINC is having most of it's work done by tablets and smart phones.
8) (Message 4383)
Posted 13 Apr 2015 by marmot
@Kyong ~380 WU received with 5 d/l error.


Several programs I use have "Memory Clean"/"Memory Usage Trim" Options:
Memory Cleaner (Koshy John)
Process Lasso
System Explorer

There are a couple apps I d/l from the PortableApps store that have those features and they are task managers.

Process Hacker - not obvious and there doesn't seem to be a global option. Choose process then rt-click -> miscellaneous -> reduce working set.
DTaskManager - rt click on any process and choose 'trim RAM to all processes'.

Thought you might be interested.

If you have the memory, run this project in a VM with a 6-8 day buffer. When you get WUs then rebalance the number of processors given to the Host OS or the VM.

Thanks, I'll try and set that up.
9) (Message 4378)
Posted 12 Apr 2015 by marmot
of course that you can, you can set it in your boinc client, in computing preferences, there is somethink like additional work buffer or somethink like that, defaultly its set to 3 days..

Sure but there are 5 projects running. If I set the buffer to 10 and there is no work for Asteroids then the other projects fill up the 10 day buffer and when WU for Asteroids finally become available Asteroids will only take a few WU down anyway.

If I could adjust the buffer differently for individual projects that would help. Asteroids is my 750/1000 resource share. I'd set the other 4 projects to 2 day buffers and Asteroids to 10 days.
10) (Message 4374)
Posted 11 Apr 2015 by marmot
Thank you for your patient. I did my moving so I really was out of time. I am moved now so I can finally continue with fixing this problem.

I bet it feels good to have the move finished.

Have we reached the point where the computing power available to Asteroids@Home is capable of completing all the work before the next weekly WU pool?

Should I increase my buffer from 2 to 10 days to get me past these periods where my machines are idle on Asteroids@Home?

Can I get an asteroid named Marmot? :)
11) (Message 4373)
Posted 11 Apr 2015 by marmot
When my machine goes into screensaver mode a text pops up saying
there are 'no tasks running'.
It has been like this since several days now.
I have been running Seti since several years and have processed
more than 3½ million units.
It feels like a waste of gpu time not getting new updates.
A few days ago I also added another project, forgot the name, but still nothing.


Lars check this thread for answers
12) (Message 4252)
Posted 25 Mar 2015 by marmot
Got 27 of 28 (1 failed d/l) and 63/63 (forgot and left it at 10 day buffer, oops) on the other machine.

Thanks Kyong
13) (Message 4242)
Posted 25 Mar 2015 by marmot

You can update several times until the project backs you off with the message 'no tasks sent you have received the allotted 1 WU for the day' in the Event Log.

I tried that, it has now stopped sending me "failed downloads" and it has stopped sending me WU's. Even when I reverted everything back the way it was.
I think I broke the Internet again? :)

I said the project would back you off, eventually, for the day. Try again tomorrow.

You should have gotten a couple of good WU out of several hundred attempts. It's about the same odds as getting a winning $5 lottery scratcher.

Admin Kyong said "New batch of workunits will have different naming scheme so it should finally work without any download errors." but he didn't say when the new WU will be showing up. I think the pattern is Thursday WU's are added so hopefully Thursday things will get better.
14) (Message 4233)
Posted 24 Mar 2015 by marmot

Just now Downloaded 77 files.

All Download Failed

All have the Deadline of 4/04/2015.

Once again, I have Aborted them.

And am continuing processing.

You don't need to abort them.

Failed downloads count as a failed WU and on the next update BOINC reports the failure and deletes them.
15) (Message 4232)
Posted 24 Mar 2015 by marmot
All my work units are now being marked "Download Failed". But my other BOINC projects are fine.

Your thoughts?

The admin knows about the problems and is working to correct them.

You can successfully get a few WU if you set all other projects to 'No New Tasks"
then go into Tools->Computing Preferences->network usage tab->Max additional work buffer = 10 days.
Then go to the project link and click Update for Asteroids@Home and the project should send 15 to 70 WU's.
Wait a minute until all the downloads are completed as failed or successful (none, or maybe 1).
You can update several times until the project backs you off with the message 'no tasks sent you have received the allotted 1 WU for the day' in the Event Log.

Remember to reset your buffer to it's original setting (usually 1 day) and then put all your Projects back to accepting new tasks.

You should end up with 3 to 10 Asteroids@Home WU's to process.
16) (Message 4222)
Posted 23 Mar 2015 by marmot
In the News section under New Workunits Kyong has posted what he found and is doing about the problem.

Thanks Mikey.

Linky to the discussion for convenience
17) (Message 4221)
Posted 23 Mar 2015 by marmot
I got about 9 WU each on two machines but it still took about 400 or 500 attempts till I got a message that no work is d/led because my machine has gotten it's allotted 1 WU for the day...

So much for being stubborn. It backfired.

Seems like we all wish we could do more to help fix the problem. Here's hoping you can resolve it with minimal further effort.
18) (Message 4211)
Posted 23 Mar 2015 by marmot
I set my buffer on these two machines to 10 days and set all projects but Asteroids@Home to 'Won't get new tasks' then tried to update both machines many times.

Out of about 1800 d/l attempts I received 4 WU's (2 WU per machine).

Are the old, corrupt WU's going to age off after a certain number of failed d/l's so that all the failed d/l's eventually improve the situation?

I'm going to assume that there is a counter on failed d/l on a WU and that the failures eventually sequester these WU.
19) (Message 4206)
Posted 22 Mar 2015 by marmot
I got 3 WU on the last approx 80 attempts but none on this machine.
20) (Message 4205)
Posted 22 Mar 2015 by marmot
I'm having serious issues getting successful downloads for the last few days. Packet truncations on every machine but no problems with any other project.

I see this is being discussed elsewhere.

Next 20