Can I reduce the GPU resource usage from "0.01 CPUs + 1 NVIDIA GPU" to "..0.8 NVDIA GPU” ?


Message boards : Number crunching : Can I reduce the GPU resource usage from "0.01 CPUs + 1 NVIDIA GPU" to "..0.8 NVDIA GPU” ?

Message board moderation

To post messages, you must log in.
AuthorMessage
hsdecalc

Send message
Joined: 1 Sep 15
Posts: 2
Credit: 6,149,974
RAC: 35
Message 4761 - Posted: 8 Jan 2016, 15:45:17 UTC
I use a GTX980 card on WIN10. Only WU from this project get my desktop to flickers.
I don’t have problems with other projects, like Einstein, Prime or Seti.

Is there an option to reduce the GPU usage?

Actual WU:
<app_file>period_search_10112_windows_x86_64__cuda55.exe</app_file>
<app_file>cudart64_55.dll</app_file>
ID: 4761 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile HA-SOFT, s.r.o.
Project developer
Project tester

Send message
Joined: 21 Dec 12
Posts: 176
Credit: 135,428,417
RAC: 9,150
Message 4762 - Posted: 8 Jan 2016, 15:57:54 UTC - in response to Message 4761.  
Not now. I will check grid dimensions for 9xx cards. Actual CUDA app was built before 9xxx had been released.
ID: 4762 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
rcthardcore

Send message
Joined: 11 Oct 16
Posts: 3
Credit: 28,320
RAC: 0
Message 5033 - Posted: 15 Oct 2016, 16:46:29 UTC
I get the same thing, GTX 980ti here. Total UI slowdown. Mouse moves in slow motion, jerky.
ID: 5033 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mmonnin

Send message
Joined: 3 Aug 16
Posts: 19
Credit: 51,522,867
RAC: 1,129
Message 5034 - Posted: 16 Oct 2016, 4:11:17 UTC
I haven't crunched before with Prime or Seti but I know that E@H does not fully utilize a GPU. Even with 3-4 WUs at once.

The stuttering arises because the Asteroids app completely utilizes your GPU, as it does mine. I sit at 99-100% most of the time. Unlike CPUs, there is no interrupts for the GPUs. It expects to process data as it comes in, in real time. When the buffer is full of compute and then there is a request to change the screen there is lag. CPUs have interrupts to insert high priority tasks and moves it to the front of queue so to speak.

There is no way to set GPU utilization % either.

Best option would try to use iGPU or another card when using the computer for daily tasks and turn off Asteroids and use your 980 for gaming as an example.
ID: 5034 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
MindCrime

Send message
Joined: 6 Mar 14
Posts: 4
Credit: 6,534,946
RAC: 356
Message 5036 - Posted: 16 Oct 2016, 5:52:07 UTC - in response to Message 5034.  

Last modified: 16 Oct 2016, 5:58:15 UTC
You can't reduce the application effects via app_info or app_config.

App_config allows you to tell boinc how many apps per project you can will allow to run or how many apps per gpu <gpu_usage>1.0...=1 _usage>0.5....=2 per gpu.

app_info can redefine which app is launched but that executable will decide how your desktop behaves.

TL;DR app_info.xml and app_config.xml aren't the answer alone.

I would check into a newer or older more stable driver. Also consider the double precision penalty.
ID: 5036 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile cliff
Avatar

Send message
Joined: 19 Nov 14
Posts: 93
Credit: 30,066,240
RAC: 0
Message 5064 - Posted: 28 Nov 2016, 5:51:30 UTC
Hi Folks,
I'm trying to get an app_config to work but keep getting errors:-/

<app_config>
<app>
<name>period_search_10200_ windows_x86_64_cuda55.exe</name>
<user_friendly_name>Period_Search_Application_102.00_(cuda55)</name>
</app>
<max_concurrent>2</max_concurrent>
<gpu_versions>
<gpu_usage>.5</gpu_usage>
<cpu_usage>.04</cpu_usage>
</gpu_versions>

Boinc doesnt see the ending </app> for some reason any ideas?
Regards,
Cliff
ID: 5064 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Conan
Avatar

Send message
Joined: 19 Jun 12
Posts: 32
Credit: 5,230,865
RAC: 1,809
Message 5065 - Posted: 28 Nov 2016, 21:55:19 UTC - in response to Message 5064.  
Hi Folks,
I'm trying to get an app_config to work but keep getting errors:-/

<app_config>
<app>
<name>period_search_10200_ windows_x86_64_cuda55.exe</name>
<user_friendly_name>Period_Search_Application_102.00_(cuda55)</name>
</app>
<max_concurrent>2</max_concurrent>
<gpu_versions>
<gpu_usage>.5</gpu_usage>
<cpu_usage>.04</cpu_usage>
</gpu_versions>

Boinc doesnt see the ending </app> for some reason any ideas?


I am not big on this stuff but don't you need </app_config> at the end of your listing to complete the file?

Conan
ID: 5065 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile cliff
Avatar

Send message
Joined: 19 Nov 14
Posts: 93
Credit: 30,066,240
RAC: 0
Message 5066 - Posted: 28 Nov 2016, 23:37:45 UTC - in response to Message 5065.  
Hi Conan,
yup, and its been included... but its still a no-go:-)
I think I'll just bin the idea for now, that card is working pcie x8 right now so maybe it wasn't such a good idea in the 1st place.
thanks for your help.
Regards,
Cliff
ID: 5066 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JugNut

Send message
Joined: 12 Jan 13
Posts: 10
Credit: 57,194,400
RAC: 0
Message 5069 - Posted: 30 Nov 2016, 6:40:22 UTC - in response to Message 5066.  
Hi Cliff, there is no point in running more than one instance at a time here at asteroids. The app uses 100% of any GPU so it's already fully utilised so no gain can be made from running more than one instance at a time and may actually decrease your overall output not to mention the extra screen lag it could cause.

But this will work to run 2 WU's at once if you'd like to try.

<app_config>
<app>
<name>period_search</name>
<gpu_versions>
<gpu_usage>0.5</gpu_usage>
<cpu_usage>1</cpu_usage>
</gpu_versions>
</app>
</app_config>
ID: 5069 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
cyrusNGC_224@P3D

Send message
Joined: 1 Apr 13
Posts: 37
Credit: 153,496,537
RAC: 0
Message 5071 - Posted: 30 Nov 2016, 10:23:32 UTC
But why one CPU core?
This app utilise only few seconds per task.
ID: 5071 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile cliff
Avatar

Send message
Joined: 19 Nov 14
Posts: 93
Credit: 30,066,240
RAC: 0
Message 5073 - Posted: 1 Dec 2016, 3:24:57 UTC - in response to Message 5069.  

Last modified: 1 Dec 2016, 3:25:20 UTC
Hi JugNut,
Nope doesn't work here, boinc sees the file, doesn't error any part of it, but nowt happens, designated gpu carry's on working 1 task.

As far as number capability, I'm running GTX 980Ti for A@H and have an 8 core CPU so can free another core for the added task.. If I could get it to work:-)
Regards,
Cliff
ID: 5073 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JugNut

Send message
Joined: 12 Jan 13
Posts: 10
Credit: 57,194,400
RAC: 0
Message 5074 - Posted: 1 Dec 2016, 6:04:59 UTC - in response to Message 5073.  

Last modified: 1 Dec 2016, 7:01:24 UTC
It definitely works I have two instances running on the GPU as I type this post using the above app_config.xml

1 Copy the the app_config as posted below and paste it into notepad then save the file as app_config.xml in C:\ProgramData\BOINC\projects\asteroidsathome.net_boinc\
*change C: for D: ect if you installed boinc to a differant drive*
Also make sure it's NOT saved as a app_config.txt or app_config.xml.txt

<app_config>
<app>
<name>period_search</name>
<gpu_versions>
<gpu_usage>0.5</gpu_usage>
<cpu_usage>1</cpu_usage>
</gpu_versions>
</app>
</app_config>

2. When back in boinc manager click on the Options menu, then click on "read config files"
A few seconds later it should start running 2 instances on 1 GPU or 4 instances if you have 2 GPU's ect.

Note: If your looking for the folder but can't find it it's because C:\ProgramData\ is a windows hidden folder. An easy way to get there is by using a keyboard shortcut. Just press the "windows key + R" together and copy the folder path noted in step 1 into the run box that appears and click OK. That will take you to the right folder for any further editing.
ID: 5074 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile cliff
Avatar

Send message
Joined: 19 Nov 14
Posts: 93
Credit: 30,066,240
RAC: 0
Message 5075 - Posted: 1 Dec 2016, 10:59:02 UTC - in response to Message 5074.  
Hi JugNut,
I've been around a bit:-) I know EXACTLY where ALL boinc related files are, including the a@h sub directory.

I don't know what OS you use or what version of boinc.
But on my rig, win7ult and boinc 7.6.22 it simply fails to do anything in the a@h sub directory, where it is supposed to go.

And I've say here watching boinc detect the app_config.xml file and ignore its settings other then 1 error message saying there was NO period search application as named only the actual cuda .exe file that WAS there and when I changed the app_config to reflect the correct filename it no longer gave an error message but simply logged the existence of the app_config.xml file and ignored its settings..
Regards,
Cliff
ID: 5075 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JugNut

Send message
Joined: 12 Jan 13
Posts: 10
Credit: 57,194,400
RAC: 0
Message 5076 - Posted: 1 Dec 2016, 13:23:23 UTC - in response to Message 5075.  

Last modified: 1 Dec 2016, 13:40:29 UTC
The PC I used to test this for you runs Win7 Ult x64 & boinc v7.6.22
http://asteroidsathome.net/boinc/results.php?hostid=64493&offset=0&show_names=0&state=4&appid=

I'm not sure exactly what you are doing wrong. But good luck anyway.
ID: 5076 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : Can I reduce the GPU resource usage from "0.01 CPUs + 1 NVIDIA GPU" to "..0.8 NVDIA GPU” ?