New CUDA application released


Message boards : News : New CUDA application released

Message board moderation

To post messages, you must log in.
AuthorMessage
Profile Kyong
Project administrator
Project developer
Project tester
Project scientist
Avatar

Send message
Joined: 9 Jun 12
Posts: 583
Credit: 52,667,664
RAC: 0
Message 7384 - Posted: 20 Nov 2022, 20:03:31 UTC
We are happy to present you our latest CUDA application v102.16!

It was built on top of CUDA's v11.8 SDK and thus it will be able to utilize the vast majority of cards with Compute Capabilities (CC) between 5.0 till 8.9 adding support for the Ampere & Ada Lovelace micro architecture, and all the Tegra & Jetson modules.
Of course, it comes with its own requirements for the driver's versions, depending on your architecture, as those before it.
In order your client to be able to receive it your computer must have one of the following Nvidia driver versions installed:

  • For Linux x86_64 and Linux AArch64 >= 450.80.02
  • For Windows x86_64 >= 452.39


(https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html)

Here is the list of supported by the v102.16 application GPUs by their CC provided by Nvidia.

So happy crunching and thank you for your support!

Radim Vančo (FoxKyong)

ID: 7384 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
biodoc

Send message
Joined: 26 Jan 13
Posts: 11
Credit: 11,242,877
RAC: 529
Message 7386 - Posted: 21 Nov 2022, 0:45:54 UTC

Last modified: 21 Nov 2022, 0:46:53 UTC
"For Linux x86_64 and Linux AArch64 >= 450.80.02"

FYi, I had to upgrade my nvidia drivers from Driver Version: 515.65.01, CUDA Version: 11.7 to Driver Version: 520.56.06, CUDA Version: 11.8 to get tasks for the new app (CUDA application v102.16) to download. Is there a server side setting that would correct this? The tasks are completing but non have validated yet.

Linux Mint 21
5.15.0-53-generic
5950X
3080Ti
boinc version 17.8.1
ID: 7386 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Keith Myers
Avatar

Send message
Joined: 16 Nov 22
Posts: 48
Credit: 427,820
RAC: 19,630
Message 7388 - Posted: 21 Nov 2022, 2:26:41 UTC
The Wikipedia page is not correct. Should not be used. Use Nvidia's gpu matrix for CUDA, driver and C.C. capability.

https://docs.nvidia.com/deploy/cuda-compatibility/

A proud member of the OFA (Old Farts Association)
ID: 7388 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Georgi Vidinski
Volunteer moderator
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 22 Nov 17
Posts: 74
Credit: 13,111,718
RAC: 1,659
Message 7391 - Posted: 21 Nov 2022, 4:49:48 UTC

Last modified: 21 Nov 2022, 4:50:28 UTC
OK, maybe we mislead you a bit.
Driver info is not from Wikipedia though. It is from the Cuda Release page for v11.8, Table.2 CUDA Toolkit and Minimum Required Driver Version for CUDA Minor Version Compatibility.

There is one condition thought:
    * Using a Minimum Required Version that is different from Toolkit Driver Version could be allowed in compatibility mode -- please read the CUDA Compatibility Guide for details.


which is described at the same link that Keith Myers provided under paragraph 3:
3. Forward Compatibility

But basically, you should stick to the Table 3. CUDA Toolkit and Corresponding Driver Versions from Cuda Release page which about Cuda toolkit v 11.8 states that:

    Linux x86_64 Driver Version must be >=520.61.05


    Windows x86_64 Driver Version must be >=522.06



Cheers,
Georgi


“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
ID: 7391 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Ian&Steve C.
Avatar

Send message
Joined: 23 Apr 21
Posts: 20
Credit: 7,198
RAC: 42
Message 7392 - Posted: 21 Nov 2022, 5:17:41 UTC - in response to Message 7391.  
OK, maybe we mislead you a bit.
Driver info is not from Wikipedia though. It is from the Cuda Release page for v11.8, Table.2 CUDA Toolkit and Minimum Required Driver Version for CUDA Minor Version Compatibility.

There is one condition thought:
    * Using a Minimum Required Version that is different from Toolkit Driver Version could be allowed in compatibility mode -- please read the CUDA Compatibility Guide for details.


which is described at the same link that Keith Myers provided under paragraph 3:
3. Forward Compatibility

But basically, you should stick to the Table 3. CUDA Toolkit and Corresponding Driver Versions from Cuda Release page which about Cuda toolkit v 11.8 states that:

    Linux x86_64 Driver Version must be >=520.61.05


    Windows x86_64 Driver Version must be >=522.06



Cheers,
Georgi



What biodoc is saying is that your new 11.8 app should work fine with older drivers as listed in the first post (CUDA 11 brought forward compatibility) but the project server will not send the new app unless it detects cuda 11.8. The app works with earlier CUDA drivers, but the project just won’t send it.

This is something you should be able to change in the project scheduler configuration. Instead of requiring cuda 11.8 from the host, you can drop it to cuda 11.1 So it will send the app to people who have 11.1+ drivers

ID: 7392 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Georgi Vidinski
Volunteer moderator
Project administrator
Project developer
Project tester
Avatar

Send message
Joined: 22 Nov 17
Posts: 74
Credit: 13,111,718
RAC: 1,659
Message 7394 - Posted: 21 Nov 2022, 5:25:57 UTC - in response to Message 7392.  

Last modified: 21 Nov 2022, 5:27:21 UTC
Actually, the plan_class for the application v103.16 was done to serve all clients with CC starting from 5.0 till the 8.9 along with the driver versions from 450.80.02 (Linux) & 452.39 (Windows).
I'll talk to Kyong to double check it.

Cheers,
Georgi
“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
ID: 7394 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Landjunge
Avatar

Send message
Joined: 2 Apr 13
Posts: 2
Credit: 11,587,025
RAC: 29,178
Message 7395 - Posted: 21 Nov 2022, 5:57:45 UTC

Last modified: 21 Nov 2022, 6:00:00 UTC
Good mornig,

Like Ian said, please make it run with older drivers for my RTX3070 under linux. Otherwise it won't be easy for me to update the drivers from 515 to 522.
ID: 7395 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Asghan

Send message
Joined: 30 Oct 19
Posts: 1
Credit: 265,584
RAC: 1,750
Message 7525 - Posted: 29 Nov 2022, 21:41:17 UTC
my 4090 with the new CUDA Apps runs fast as hell.
<2min per WU :-)
ID: 7525 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
computezrmle

Send message
Joined: 20 Feb 13
Posts: 3
Credit: 38,880,003
RAC: 1,682
Message 7528 - Posted: 30 Nov 2022, 10:25:40 UTC
After a GPU driver upgrade to version 525.53 my cards got tasks from this app:
Period Search Application v102.15 (cuda102_linux)

As far as I understand they should instead get the new version 102.16 (cuda118_linux).
https://asteroidsathome.net/boinc/show_host_detail.php?hostid=723403
https://asteroidsathome.net/boinc/show_host_detail.php?hostid=723405
ID: 7528 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : News : New CUDA application released