Posts by PSL
log in
1) Message boards : Problems and bug reports : "period_search_1" uses deprecated CP15 Barrier instruction (Message 7069)
Posted 21 Sep 2020 by PSL
I noticed following messages on ARM SBC running the latest Armbian (arm64) with armhf support. These messages are from "dmesg" output:


[ 186.540142] "period_search_1" (1797) uses deprecated CP15 Barrier instruction at 0x2d1c8 [ 186.540815] "period_search_1" (1798) uses deprecated CP15 Barrier instruction at 0x2d1c8 [ 186.556392] "period_search_1" (1797) uses deprecated CP15 Barrier instruction at 0x40990 [ 186.556401] "period_search_1" (1799) uses deprecated CP15 Barrier instruction at 0x409c0


$ uname -a Linux lepotato 5.8.10-meson64 #20.08.3 SMP PREEMPT Fri Sep 18 11:40:58 CEST 2020 aarch64 aarch64 aarch64 GNU/Linux $ dpkg --print-foreign-architectures armhf $ boinccmd --client_version Client version: 7.16.6
2) Message boards : Problems and bug reports : Period Search Application needs 13.20MB more disk space (Message 6272)
Posted 7 May 2019 by PSL
I think there is a bug in A@H or in Boinc client. I cannot get new tasks for A@H at PC that has more than 160GB of free disk space. The error in event log is:

Tue 07 May 2019 04:05:13 PM CEST | Asteroids@home | Message from server: Period Search Application needs 13.20MB more disk space. You currently have 82.17 MB available and it needs 95.37 MB.


I have another computer that is connected to A@H and that one really has just about 80MB of free disk space. But why one computer blocks other?? These are indipendent computers...
3) Message boards : Wish list : aarch64-unknown-linux-gnu (Message 6153)
Posted 17 Jan 2019 by PSL
Could you add application for ARM64, "aarch64-unknown-linux-gnu"?

I tried SETI@home and I see that performance of ARM64 application is almost double of ARM32 application.

I tried with AWS instance a1.medium, that is Amazon Graviton EC2 instance, it supports "aarch64-unknown-linux-gnu" and "arm-unknown-linux-gnueabihf".

There are already several Boinc projects those support ARM64 processors. I know about these:
- SETI@home
- Universe@home
- Amicable Numbers
- Distibuted Hardware Evolution Project
- Yoyo@home

Could be the list extended with Asteroids@home?? So far, ARM64 hardware has to be configured to run 32-bit code and that has significant impact to performance. Some ARM cores cannot run 32-bit code at all (like ARM64 instances at Sceleway - ARM processor is Cavium ThunderX).

ARM64 code can be tested with single board Odroid-C2 or EC2 ARM instances in Amazon AWS or ARM64 instances in Scaleway cluster. Ubuntu Linux was running on these instances.




Main page · Your account · Message boards


Copyright © 2021 Asteroids@home